2025年WHIOS协议规范如下(原文引用)

WHIOS协议规范如下(原文引用)本文介绍的是一种查询域名所有权信息的方法 对于称为 WHOIS 的 IRC 命令 请参阅 Internet 中继聊天命令列表 WHOIS WHOIS 发音为短语 who is 是一种查询和响应协议 广泛用于查询存储注册用户或互联网资源受让人的数据库 例如域名 IP 地址块或自治系统 但也用于更广泛的其他信息

大家好,我是讯享网,很高兴认识大家。

Whois 也是大多数UNIX系统上用于进行 WHOIS 协议查询的命令行实用程序的名称。[2]此外,WHOIS 有一个名为Referral Whois ( RWhois ) 的姊妹协议。


内容
1个    历史
1.1    CRISP 和 IRIS
1.2    怪异和 RDAP
2个    协议
2.1    强化
3个    执行
3.1    精简查找和详细查找
3.2    软件
3.3    网络
4个    服务器
4.1    区域互联网注册机构
4.2    服务器发现
5个    查询示例
6个    推荐域名
7    批评
8个    信息的准确性
9    法律与政策
10    ICANN 提议废除 WHOIS
11    标准文件
12    也可以看看
13    参考
13.1    来源
14    外部链接
历史

此部分需要额外的引用以供验证。请通过添加对可靠来源的引用来帮助改进这篇文章。无法查证的内容可能被提出异议而移除。查找来源:“WHOIS”  —— 新闻·报纸·书籍·学者· JSTOR
         (2017 年 2 月)(了解如何以及何时删除此模板消息)
Elizabeth Feinler和她的团队(曾为ARPANET创建资源目录)负责在 70 年代初期创建第一个 WHOIS 目录。[3] Feinler 在斯坦福大学的网络信息中心 (NIC)设立了一个服务器,作为一个目录,可以检索有关人或实体的相关信息。[4]她和团队根据 Feinler 的建议创建了域,即根据计算机的物理地址对域进行分类。[5]

注册过程在RFC 920中建立。WHOIS 在 1980 年代初期被标准化,用于查找与域和号码注册相关的域、人员和其他资源。由于当时所有注册均由一个组织完成,因此使用一台中央服务器进行 WHOIS 查询。这使得查找此类信息变得非常容易。  

在 ARPANET 出现互联网时,唯一处理所有域注册的组织是美国政府的国防高级研究计划局 (DARPA) (创建于 1958 年[6])。随着 ARPANET 在 1980 年代成为互联网,域名注册的责任仍然由 DARPA 负责。UUNET开始提供域名注册服务;然而,他们只是处理了他们转发给 DARPA 网络信息中心 (NIC) 的文书工作。然后,国家科学基金会指示互联网域名注册的管理将由商业第三方实体处理。网际网卡于 1993 年根据与 NSF 签订的合同成立,由Network Solutions, Inc.、General Atomics和AT&T组成。由于性能问题,通用原子合同在几年后被取消。

20 世纪的 WHOIS 服务器非常宽松,允许通配符搜索。一个人的姓氏的 WHOIS 查询将产生所有具有该名字的人。使用给定关键字的查询返回包含该关键字的所有注册域。对给定管理联系人的查询返回了管理员关联的所有域。由于商业化互联网、多个注册商和不道德的垃圾邮件发送者的出现,这种宽松的搜索不再可用。

1999 年 12 月 1 日,顶级域名(TLD) com、net和org的管理权交给了ICANN。当时,这些 TLD 已转换为精简 WHOIS 模型。现有的 WHOIS 客户端当时停止工作。一个月后,它有了自我检测通用网关接口支持,这样同一个程序就可以运行基于 Web 的 WHOIS 查询,以及一个外部 TLD 表来支持基于请求的 TLD 的多个 WHOIS 服务器。这最终成为现代 WHOIS 客户端的模型。

到 2005 年,通用顶级域的数量比 1980 年代初期多得多。还有更多的国家代码顶级域。这导致了域名注册商和注册商协会的复杂网络,尤其是在互联网基础设施的管理变得更加国际化的情况下。因此,对域执行 WHOIS 查询需要知道要使用的正确、权威的 WHOIS 服务器。执行 WHOIS 域搜索的工具已变得很普遍,并且由 IONOS 和 Namecheap 等提供商提供。[7]

3981 -牛顿,一个。Sanz, M.(2005 年 1 月)。IRIS:互联网注册信息服务 (IRIS) 核心协议。互联网工作组。内政部:10.17487 /RFC3981。标准8.RFC 3981 。2015 年6 月 1日检索。
3982 -牛顿,一个。Sanz, M.(2005 年 1 月)。IRIS:互联网注册信息服务 (IRIS) 的域注册 (dreg) 类型。互联网工作组。内政部:10.17487 /RFC3982。RFC 3982 。2015 年6 月 1日检索。
3983 -牛顿,一个。Sanz, M.(2005 年 1 月)。通过块可扩展交换协议 (BEEP) 使用 Internet 注册信息服务 (IRIS)。互联网工作组。内政部:10.17487 /RFC3983。RFC 3983 。2015 年6 月 1日检索。
4992 -牛顿,A.(2007 年 8 月)。用于 Internet 注册信息服务的带有块的 XML 流水线。互联网工作组。内政部:10.17487 /RFC4992。RFC 4992 。2015 年6 月 1日检索。
可以在IETF 工具站点上找到该小组处理的 RFC 的状态。[11]

截至 2009 年 3 月,CRISP IETF 工作组得出结论,[12]在该组[13] Newton, Andrew发布了最终的 RFC 5144 之后;Sanz, Marcos(2008 年 2 月)。互联网注册信息服务 (IRIS) 的域可用性检查 (DCHK) 注册类型。互联网工作组。内政部:10.17487 /RFC5144。征求意见稿5144 。2015年6 月 1 日检索。 .

注意:不要将 IETF CRISP 工作组与同名的号码资源组织(NRO) 团队“联合 RIR IANA 管理提案团队”(CRISP 团队)混淆。[14]

WEIRDS 和 RDAP 
主条目:注册数据访问协议
2013 年,IETF 承认 IRIS 未能成功替代 WHOIS。主要原因似乎是 IRIS 的复杂性。此外,非技术原因被认为存在于 IETF 未做出判断的领域。同时,ARIN和RIPE NCC设法通过RESTful Web 服务提供 WHOIS 数据。该章程(2012 年 2 月起草)规定了单独的规范,首先是号码注册,然后是名称注册。[15]工作组提出了五份拟议标准文件:

7480 -牛顿,安德鲁; 埃拉科特,拜伦;孔宁(2015 年 3 月)。注册数据访问协议 (RDAP) 中的 HTTP 使用。互联网工作组。内政部:10.17487 /RFC7480。RFC 7480 。2015 年7 月 8日检索。
7481 -霍伦贝克,斯科特;孔宁(2015 年 3 月)。注册数据访问协议 (RDAP) 的安全服务。互联网工作组。内政部:10.17487 /RFC7481。RFC 7481 。2015 年7 月 8日检索。
7482 -牛顿,安德鲁; Hollenbeck, Scott(2015 年 3 月)。注册数据访问协议 (RDAP) 查询格式。互联网工作组。内政部:10.17487 /RFC7482。RFC 7482 。2015 年7 月 8日检索。
7483 -牛顿,安德鲁; Hollenbeck, Scott(2015 年 3 月)。注册数据访问协议 (RDAP) 的 JSON 响应。互联网工作组。内政部:10.17487 /RFC7483。RFC 7483 。2015 年7 月 8日检索。
7484 -布兰切特,马克(2015 年 3 月)。查找权威注册数据 (RDAP) 服务。互联网工作组。内政部:10.17487 /RFC7484。RFC 7484 。2015 年7 月 8日检索。
和信息文件:

7485 -周,L。孔,N。沉,S。盛,S。Servin, A.(2015 年 3 月)。WHOIS 注册对象的清点和分析。互联网工作组。内政部:10.17487 /RFC7485。RFC 7485 。2015 年7 月 8日检索。
协议
WHOIS 协议起源于 ARPANET NICNAME 协议,并基于RFC 742 (1977)中描述的NAME/FINGER 协议。1982 年, SRI International网络信息中心的 Ken Harrenstien 和 Vic White在RFC 812中首次描述了 NICNAME/WHOIS 协议。   

WHOIS 最初是在网络控制协议(NCP) 上实施的,但是当TCP/IP套件在 ARPANET 和后来的 Internet 上标准化时,发现了它的主要用途。

协议规范如下(原文引用):[16]

连接到服务主机
   TCP:服务端口 43(十进制)
   NCP:ICP to socket 43 decimal,建立两个8位连接
发送单个“命令行”,以 <CRLF> 结尾。
接收响应命令行的信息。这
一旦输出是服务器关闭它的连接
完成的。
命令行服务器查询通常是单个名称规范。即资源的名称。但是,服务器接受一个仅包含问号 (?) 的查询,以返回可接受的命令行格式的描述。替换或通配符格式也存在,例如,将句点(句点)附加到查询名称将返回所有以查询名称开头的条目。

在现代互联网上,WHOIS 服务通常使用传输控制协议(TCP) 进行通信。服务器在众所周知的端口号43 上侦听请求。客户端是简单的应用程序,它们与服务器建立通信通道,传输包含要查询的资源名称的文本记录,并等待文本序列形式的响应在数据库中找到的记录。该协议的这种简单性还允许应用程序和命令行界面用户使用Telnet协议查询 WHOIS 服务器。

状态码    描述
添加期间    此宽限期在域名初始注册后提供。如果注册服务商在此期间删除了域名,则注册管理机构可能会向注册服务商提供注册费用信用额度。
自动更新周期    此宽限期在域名注册期到期后提供,并由注册管理机构自动延长(续订)。如果注册服务商在此期间删除了域名,则注册管理机构会向注册服务商提供续订费用的信用额度。
不活跃    此状态代码表示授权信息(名称服务器)尚未与域相关联。该域未在DNS中激活,因此不会解析。
好的    这是域的标准状态,意味着它没有待处理的操作或禁止。
待创建    此状态代码表示已收到并正在处理创建域的请求。
待删除    此状态代码可能与redemptionPeriod或pendingRestore混合使用。在这种情况下,根据域名中设置的状态,否则(不与其他状态结合),pendingDelete状态代码表示该域已处于 redemptionPeriod 状态 30 天且未恢复。该域将保持此状态几天,之后该域将从注册数据库中删除。
一旦发生删除,该域可根据注册管理机构的政策重新注册。

待更新    此状态代码表示已收到并正在处理更新域的请求。
待恢复    此状态代码表示您的注册商已要求注册局恢复处于 redemptionPeriod 状态的域。在等待您的注册服务商提供所需的恢复文档时,您的注册管理机构会将域保持此状态。如果您的注册商未能在规定的时间段内向注册管理运行机构提供文件以确认恢复请求,则该域将恢复为 redemptionPeriod 状态。
待转账    此状态代码表示已收到并正在处理将域转移到新注册商的请求。
待更新    此状态代码表示已收到并正在处理更新域的请求。
赎回期    此状态代码表示您的注册商已要求注册管理机构删除域。该域将保持此状态 30 天。在 redemptionPeriod 结束后的五个日历日后,该域将从注册数据库中清除并可供注册。
更新期    此宽限期是在注册商明确延长(续订)域名注册期后提供的。如果注册服务商在此期间删除了域名,则注册管理机构会向注册服务商提供续订费用的信用额度。
服务器删除禁止    此状态代码可防止域被删除。这是一种不常见的状态,通常在法律纠纷期间、应您的请求或在出现赎回期状态时生效。
服务器保持    此状态代码由域的注册管理机构设置。该域未在DNS中激活。
服务器更新禁止    此状态代码表示域的注册管理机构不允许您的注册商续订域。这是一种不常见的状态,通常在法律纠纷或域被删除时出现。
服务器传输禁止    此状态代码可防止域从您当前的注册商转移到另一个。这是一种不常见的状态,通常在法律或其他纠纷期间、应您的请求或在赎回期状态到位时生效。
服务器更新禁止    此状态代码锁定域以防止其更新。这是一种不常见的状态,通常在法律纠纷期间、应您的请求或在出现赎回期状态时生效。
转让期    此宽限期是在域名从一个注册商成功转移到另一个注册商之后提供的。如果新注册商在此期间删除了域名,则注册管理机构会向注册商提供转移费用的信用额度。
实施
WHOIS 查询传统上是使用命令行界面应用程序执行的,但现在存在许多替代的基于 Web 的工具。

WHOIS 数据库由每个资源的一组文本记录组成。这些文本记录包含有关资源本身的各种信息,以及受让人、注册人的任何相关信息、管理信息,例如创建和到期日期。

存在两种数据模型用于在 WHOIS 数据库中存储资源信息,厚模型和精简模型。

厚的
详细 WHOIS 服务器存储来自所有注册商的特定数据集的完整 WHOIS 信息(例如,一个 WHOIS 服务器可以响应所有.org域的 WHOIS 信息)。
薄的
精简 WHOIS 服务器仅存储域注册商的 WHOIS 服务器的名称,而该名称又包含有关正在查找的数据的完整详细信息(例如.com WHOIS 服务器,它将 WHOIS 查询提交给注册商,其中域已注册)。
厚模型通常确保一致的数据和稍快的查询,因为只需要联系一个 WHOIS 服务器。如果注册服务商倒闭,厚注册表包含所有重要信息(如果注册人输入了正确的数据,并且没有使用隐私功能来隐藏数据)并且可以保留注册信息。但是对于一个薄的注册管理机构,联系信息可能不可用,并且合法的注册人可能很难保留对域的控制权。[18]

如果 WHOIS 客户端不知道如何处理这种情况,它会显示来自注册商的完整信息。不幸的是,WHOIS 协议没有确定如何区分精简模型和厚模型的标准。

存储哪些记录的具体细节因域名注册机构而异。一些顶级域,包括com和net,运行一个瘦 WHOIS,要求域注册商维护他们自己客户的数据。其他全球顶级注册管理机构(包括org)采用厚模型。[19]每个国家代码顶级注册机构都有自己的国家规则。

软件
谁是
Whois Mushoku Tensei screenshot.png
开发商    RIPE NCC(原始 BSD 客户端)、Marco d'Itri(现代 Linux 客户端)
操作系统    Unix ,类 Unix , ReactOS [20]
平台    跨平台
类型    命令
执照    BSD 许可证(BSD 和 ReactOS),GPL (Linux)
网站    github.com/rfc1036/whois _ _ _
为 WHOIS 信息系统编写的第一个应用程序是用于Unix和类 Unix操作系统(即 Solaris、Linux 等)的命令行界面工具。WHOIS 客户端和服务器软件作为免费开源软件分发,二进制分发版包含在所有类 Unix系统中。各种商业 Unix 实现可能使用专有实现(例如,Solaris 7)。

WHOIS 命令行客户端将作为参数给出的短语直接传递给 WHOIS 服务器。仍然可以在 sourceforge.net 等站点上找到各种免费的开源示例。但是,大多数现代 WHOIS 工具都实施命令行标志或选项,例如用于访问特定服务器主机的 -h 选项,但默认服务器是预先配置的。其他选项可能允许控制要连接的端口号、显示其他调试数据或更改递归/引用行为。

与大多数 TCP/IP客户端-服务器应用程序一样,WHOIS 客户端接受用户输入,然后打开到其目标服务器的Internet 套接字。WHOIS 协议管理查询的传输和结果的接收。


讯享网

目前,基于 Web 的 WHOIS 客户端通常直接执行 WHOIS 查询,然后格式化结果以供显示。许多此类客户端都是专有的,由域名注册商授权。

对基于 Web 的客户端的需求来自命令行 WHOIS 客户端主要只存在于 Unix 和大型计算世界中这一事实。默认情况下, Microsoft Windows和 Macintosh 计算机没有安装 WHOIS 客户端,因此注册商必须找到一种方法为潜在客户提供对 WHOIS 数据的访问权限。许多最终用户仍然依赖此类客户端,尽管现在大多数家庭 PC 平台都存在命令行和图形客户端。Microsoft 免费提供包含 whois 客户端 的Sysinternals Suite 。

CPAN有几个可用于 WHOIS 服务器的Perl模块。其中许多不是最新的,并且不能完全与当前 (2005) WHOIS 服务器基础设施一起使用。但是,仍然有很多有用的功能可以派生,包括查找AS 编号和注册人联系方式。[需要引用]

区域互联网注册管理机构

每个注册管理机构的记录都是交叉引用的,因此向ARIN查询属于RIPE的记录将返回一个指向 RIPE WHOIS 服务器的占位符。这让进行查询的 WHOIS 用户知道详细信息驻留在 RIPE 服务器上。除了 RIR 服务器之外,还存在商业服务,例如一些大型网络使用的路由资产数据库(例如,在几个 RIR 地区收购了其他 ISP 的大型互联网提供商)。

一些注册管理机构运营商是批发商,这意味着他们通常向大量零售注册商提供域名服务,而这些零售注册商又将这些服务提供给消费者。对于私人注册,只能返回批发注册商的身份。在这种情况下,可能会隐藏个人以及零售注册商的身份。

以下是为单个资源所有者返回的 WHOIS 数据示例。这是example.com的 WHOIS 查询结果:

whois example.com
[查询whois.verisign-grs.com]
[重定向至www.qingyanggong.org]
[查询whois.iana.org]
[whois.iana.org]
% IANA WHOIS 服务器
% 有关 IANA 的更多信息,请访问 http://www.iana.org
% 这个查询返回了 1 个对象
域名:EXAMPLE.COM
组织:互联网号码分配机构
创建时间:1992-01-01
资料来源:IANA

IP 地址分配的查找通常限于较大的无类域间路由(CIDR) 块(例如 /24、/22、/16),因为通常只有区域互联网注册管理机构(RIR) 和域注册商运行 RWhois 或 Whois服务器,尽管 RWhois 旨在由更小的本地 Internet 注册管理机构运行,以提供有关 IP 地址分配的更详细信息。

RWhois 旨在取代 Whois,提供一种有组织的推荐服务层次结构,人们可以在其中连接到任何 RWhois 服务器,请求查找并自动重定向到正确的服务器。然而,虽然技术功能已经到位,但 RWhois 标准的采用一直很薄弱。

RWhois 服务通常使用传输控制协议(TCP) 进行通信。服务器在众所周知的端口号4321 上侦听请求。

Rwhois于 1994 年由Network Solutions [27]在RFC 1714中首次指定,但该规范于 1997 年被RFC 2167取代。[28]  

RWhois 的引用功能不同于 Whois 服务器将响应引用到另一台服务器的功能,RWhois 也实现了这一功能。

其他人引用域隐私的竞争目标作为批评,尽管域隐私服务极大地缓解了这个问题。目前,互联网名称与数字地址分配机构( ICANN ) 广泛要求邮寄 地址、电话号码和电子邮件地址拥有或管理域名的人可以通过“WHOIS”目录公开访问。查询 WHOIS 服务器的任何人都可以轻松访问注册人(域所有者)的详细联系信息,例如地址和电话号码。但是,该策略使垃圾邮件发送者、直销商、身份盗用者或其他攻击者能够掠夺目录以获取有关这些人的个人信息。尽管 ICANN 一直在探索改变 WHOIS 以实现更好的隐私,但主要利益相关方之间对于应该进行何种类型的改变缺乏共识。[31]一些域注册商提供私人注册(也称为域隐私),其中显示注册商的联系信息而不是客户的联系信息。由于许多注册服务商提供私人注册,部分风险已得到缓解。[32]

研究表明,垃圾邮件发送者可以并且确实从 WHOIS 服务器获取纯文本电子邮件地址。[33]出于这个原因,一些 WHOIS 服务器和提供 WHOIS 查询的网站实施了速率限制系统,例如基于 Web 的验证码和每个用户IP 地址的搜索查询数量有限。[32]

WHOIS 要求与 2018 年 5 月 25 日在欧盟生效的通用数据保护条例(GDPR) 相冲突,该条例对个人身份信息的处理和发布做出了严格规定。ICANN 在 2017 年 11 月表示,如果注册商提供替代解决方案以遵守其规则,它不会谴责“不遵守与处理注册数据相关的合同义务”,直到更新 WHOIS 要求以将 GDPR 考虑在内。[32] [34]

WHOIS 协议并不是为国际受众编写的。WHOIS 服务器和/或客户端无法确定对查询或数据库内容有效的文本编码。许多服务器最初使用 US- ASCII,直到很久以后才考虑国际化问题。[35]这可能会影响 WHOIS 协议在美国以外国家/地区的可用性或实用性。[1]对于国际化域名,客户端应用程序负责在其本地语言脚本和punycode中的 DNS 名称之间执行域名转换。

在私人注册的情况下,确定注册信息可能更加困难。如果获得域名的注册人想要验证注册服务商是否已完成注册过程,则可能需要三个步骤:

执行 WHOIS 并确认该资源至少已在 ICANN 注册,
确定批发注册商的名称,以及
联系批发商并获取零售注册商的名称。
这为零售商实际注册了该名称提供了一定的信心。但如果注册商倒闭,就像2007 年RegisterFly的失败一样,具有隐私保护注册的合法域名持有者可能难以重新获得其域名的管理权。[18]使用“私人注册”的注册人可以尝试通过使用将客户数据交给第三方托管的注册服务商来保护自己。

ICANN 要求每个域名注册人都有机会更正与其域相关的任何不准确的联系数据。为此,注册服务机构需要定期向持有人发送记录在案的联系信息以供核实,但如果注册人提供的信息不准确,他们不对信息的准确性提供任何保证。

法律和政策
地球图标。
本节中的示例和观点主要针对美国,并不代表世界范围内对该主题的看法。您可以根据需要改进此部分,在讨论页上讨论该问题,或创建一个新部分。 (2018 年 5 月)(了解如何以及何时删除此模板消息)
WHOIS 在美国联邦政府中产生了政策问题。如上所述,WHOIS 造成隐私问题,该问题也与言论自由和匿名相关。但是,WHOIS 是执法人员调查垃圾邮件和网络钓鱼等违规行为以追查域名持有人的重要工具。因此,执法机构试图公开和验证 WHOIS 记录:[36]

联邦贸易委员会已就不准确的 WHOIS 记录如何阻碍他们的调查作证。[37]
2001 年、2002 年和 2006 年就 WHOIS 的重要性举行了国会听证会。[38]
《欺诈性在线身份制裁法》[39] “如果某人在制作、维护或更新用于域名的注册时故意提供或导致提供严重虚假的联系信息,则构成对商标和版权法的违反connection with the violation”,[40]后面的“违反”指的是先前违反商标法或版权法。该法案并未将提交虚假 WHOIS 数据本身定为非法,除非用于保护自己免于因使用该域名实施的犯罪而受到起诉。
ICANN 废除 WHOIS 的提议
互联网名称与数字地址分配机构 ( ICANN ) 专家工作组 (EWG) 于 2013 年 6 月 24 日建议废除 WHOIS。它建议将 WHOIS 替换为一个对大多数互联网用户保密的系统,并且只为“允许的目的”披露信息。[41] ICANN 的允许用途清单包括域名研究、域名买卖、监管执法、个人数据保护、法律诉讼和滥用缓解。[42]尽管 WHOIS 一直是记者确定谁在互联网上传播某些信息的关键工具,[43]自由媒体对 WHOIS 的使用不包括在 ICANN 提议的允许用途列表中。

EWG 在 2013 年 9 月 13 日之前收集了对初始报告的公众意见。其最终报告于 2014 年 6 月 6 日发布,未对建议进行有意义的更改。[44]截至 2015 年 3 月,ICANN 正处于“重新发明 WHOIS 的过程”中,致力于“ICANN WHOIS 测试版”。[45] [46]

小讯
上一篇 2025-03-17 16:48
下一篇 2025-02-20 07:53

相关推荐

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容,请联系我们,一经查实,本站将立刻删除。
如需转载请保留出处:https://51itzy.com/kjqy/72988.html